Back to overview
Resolved
API timeouts causing dashboard errors
Jun 22, 2026 at 8:10am UTC
Affected services
API (EU)
Resolved
Jun 22, 2026 at 8:25am UTC
We identified the issue behind the dashboard timeouts. Basic health checks stayed green, but user-facing dashboard RPC routes were timing out while upstream API calls were completing very slowly, often near the dashboard proxy deadline. This caused 502/504s across deal, document, hygiene, workspace, CIM, and event-stream routes, including some save paths.
Affected services
Created
Jun 22, 2026 at 8:10am UTC
API timeouts causing dashboard errors
Affected services