Back to overview
Resolved

Temporary dashboard performance degradation

Jun 19, 2026 at 2:46pm UTC
Affected services
Application (EU)
API (EU)

Resolved
Jun 19, 2026 at 3:11pm UTC

We’ve resolved the issue that caused degraded dashboard performance. Increased platform usage put pressure on backend resources, which led to intermittent slowness and errors for some users.

We have increased backend capacity, adjusted scaling limits, and are continuing to monitor the platform closely. Usage can now continue normally.

Created
Jun 19, 2026 at 2:46pm UTC

We saw increased platform usage that exceeded the resource profile we had provisioned, causing temporary degraded performance for some users. We’ve increased backend capacity and are monitoring the system to ensure usage can continue smoothly.